Site unavailable
Incident Report for backdrop
Resolved
We identified the cause of the issue and found it was due to the replacement of a certificate and the application hadn't picked up the change.
We were able to resolve this by forcing the change.
Posted Jul 19, 2022 - 15:22 BST
Identified
The issue has been identified and a fix is being implemented.
Posted Jul 19, 2022 - 13:23 BST
This incident affected: US.