Backdrop - Intermittent Connectivity Issues

Incident Report for backdrop

Resolved

This incident has been resolved.
Posted Feb 10, 2026 - 19:46 GMT

Monitoring

Our DNS provider is currently reporting infrastructure disruptions which may cause intermittent issues connecting to Backdrop. They are currently working to resolve this issue, and we will continue to monitor any issues.
Posted Feb 10, 2026 - 17:43 GMT
This incident affected: AU, CA, EU, UK, US, and US2.