uk.backdrop.cloud
Incident Report for backdrop
Resolved
This incident has been resolved.
Posted Nov 14, 2024 - 13:32 GMT
Investigating
We are currently investigating this issue.
Posted Nov 14, 2024 - 10:34 GMT
This incident affected: UK.