us2.backdrop.cloud - Slow performance
Incident Report for backdrop
Resolved
This incident has been resolved.
Posted Sep 13, 2024 - 21:51 BST
Monitoring
A fix has been implemented and we are monitoring the results.
Posted Sep 13, 2024 - 17:20 BST
Update
Customers using us2.backdrop.cloud may experience intermittent page loading issues and slow performance
Posted Sep 13, 2024 - 16:58 BST
Investigating
We are currently investigating this issue.
Posted Sep 13, 2024 - 16:57 BST
This incident affected: US2.