Failure on an upstream partners' network
Incident Report for backdrop
Resolved
Our upstream provider has restored services which were affecting our systems.
Posted Feb 17, 2023 - 18:34 GMT
Identified
We are aware of a problem with an upstream partner which is currently impact some of our regional services.

At this time, our customers who access our services via https://ca.backdrop.cloud will experience problems accessing our services.
Posted Feb 17, 2023 - 17:14 GMT
This incident affected: CA.