Device connectivity issues
Incident Report for backdrop
Resolved
This incident has been resolved.
Posted Sep 02, 2022 - 07:39 BST
Monitoring
We have identified the root cause of the recent issues as a DDOS attack from unknown sources. We have mitigated the attack and brought all services back online. We will continue to monitor for additional malicious behaviour and have begun reinforcing our security posture and addressing our attack mitigations strategies.
Initial analysis indicates this was a DDOS attack that has not resulted in data loss or unauthorised access to data or systems. Analysis will continue with further communication released according to the Impero Data breach Policy.
Posted Sep 01, 2022 - 21:37 BST
Identified
We have identified the service failing and are working on multiple tasks to mitigate the issue. We are actively engaged with the support team of our upstream provider to mitigate the issue.
Posted Sep 01, 2022 - 17:51 BST
Update
During our investigations we were able to identify a failure in functionality provided by an upstream provider.
We were able to resolve this in part and are now investigating the functionality provided via a second upstream provider which affects the connection of student devices to the Classroom function in Backdrop.
Posted Sep 01, 2022 - 16:37 BST
Update
Devices are having issues connecting to Backdrop.
Posted Sep 01, 2022 - 16:01 BST
Investigating
We are currently investigating this issue.
Posted Sep 01, 2022 - 16:00 BST
Update
We are continuing to monitor for any further issues.
Posted Sep 01, 2022 - 13:55 BST
Monitoring
A fix has been implemented and we are monitoring the results.
Posted Sep 01, 2022 - 13:52 BST
Investigating
We are currently investigating this issue.
Posted Sep 01, 2022 - 13:15 BST
This incident affected: AE, AU, CA, EU, UK, US, and US2.