Website unavailable

Incident Report for backdrop

Resolved

We have applied mitigation for the issue on us2.backdrop.cloud whereby users of the service would have been unable to connect. We have been monitoring this for the last hour and the mitigation has resolved the issue.
We will continue to monitor the situation.
Posted Sep 27, 2023 - 19:21 BST

Update

We are continuing to investigate this issue.
Posted Sep 27, 2023 - 19:18 BST

Investigating

We are currently investigating this issue.
Posted Sep 27, 2023 - 17:45 BST
This incident affected: US2.