Unable to login
Incident Report for backdrop
Resolved
We have resolved the issue.
Posted Jun 10, 2022 - 13:23 BST
Update
We are continuing to investigate this issue.
Posted Jun 10, 2022 - 13:01 BST
Investigating
We are currently investigating potential causes.
Posted Jun 10, 2022 - 12:46 BST
This incident affected: AE, AU, CA, EU, UK, and US.